Issue with Public API, Uploads and Downloads
Incident Report for Box
Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we will update as more information is confirmed.

 On October 28th, 2021 between 7:40 PM PDT and 8:26 PM PDT, some users may have experienced difficulties while working in Box. During this time, impacts to uploads and downloads was observed. The issue occurred as a result of a recent code change. We were able to resolve the issue by moving traffic to another data center. In addition, we are working to enhance our code change testing procedures as well as increase our monitoring/alerting of this service to prevent similar issues from occurring in the future. 

We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. We will publish the results as soon as we have concluded our investigation.

 We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

 

Sincerely,

The Box Team

Posted Jan 12, 2022 - 17:26 PST

Resolved
From approximately 7:40pm - 8:26pm PST on October 29th, some users may have experienced issues with Downloads, Notes, Public API, Uploads. Our teams have taken action to remediate this behavior and no additional impact has been observed. Please contact Box Support at https://support.box.com if you are currently seeing any issues.
Posted Oct 29, 2021 - 10:30 PDT