[Minor] Issues with Uploads and Box Notes
Incident Report for Box
Postmortem

NOTICE AND DISCLAIMER: CUSTOMER UNDERSTANDS AND AGREES THAT THIS IS PRELIMINARY INFORMATION SUBJECT TO FURTHER REVIEW AND ANALYSIS BY BOX. TO THE BEST OF OUR KNOWLEDGE, THIS IS THE CURRENT STATE AND WILL BE UPDATED AS MORE INFORMATION IS CONFIRMED.

LAST UPDATED: July 29, 2020

We recently addressed issues affecting uploads, downloads and Box Notes. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 10:56 pm and 11:39 pm PDT on July 13th, 2020, some users may have experienced difficulties while working in Box. During this time, Box users may have experienced a degradation to services such as uploads, downloads and Box Notes. The issue occurred as a result of Box Metadata API causing elevated levels of timeouts that impacted uploads/downloads and Box Notes. The issue was resolved after rate limiting Box Metadata API. In addition, we are working to improve our testing processes to prevent similar issues from occurring in the future.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Jul 29, 2020 - 08:40 PDT

Resolved
We have completed our monitoring period and are considering the issue fully resolved. If you are seeing any new issues, please let us know at https://support.box.com.
Posted Jul 14, 2020 - 00:08 PDT
Monitoring
We have remediated the impact and are now monitoring to ensure no further impact is observed. The next update will be provided here in approximately 30 minutes or if there is any change in the issue's status.
Posted Jul 14, 2020 - 00:00 PDT
Investigating
We are investigating an issue which may result in impact to Uploads and Box Notes. Additional information will be provided as it becomes available.
Posted Jul 13, 2020 - 23:28 PDT
This incident affected: Box Notes (Web Application, Desktop Client), Box Web Application (Uploads/Downloads), and Box Platform / API (Uploads/Downloads).