[Critical] Issues with Accessing Content, Logins, Public API, Uploads, and Downloads
Incident Report for Box
Postmortem

NOTICE AND DISCLAIMER: BOX IS PROVIDING THIS PRELIMINARY INFORMATION SUBJECT TO FURTHER REVIEW AND ANALYSIS. TO THE BEST OF OUR KNOWLEDGE, THIS IS THE CURRENT STATE AND WE WILL UPDATE AS MORE INFORMATION IS CONFIRMED.

LAST UPDATED: OCTOBER 21, 2020

We recently addressed issues affecting Box Services. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 5:35 AM PDT and 9:15 AM PDT on October 19, 2020, some users may have experienced difficulties while working in Box. During this time, some users may have experienced increased latency and errors with login, uploads, downloads, and public API calls.

The issue occurred as a result of a slowdown in interactions between critical services caused by hosts in an unhealthy state. We were able to resolve the issue by taking hosts out of rotation.  In addition, we are auditing interactions between the impacted services to adjust timeouts to increase the robustness of interactions between these services and prevent similar issues from occurring in the future.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Oct 21, 2020 - 07:36 PDT

Resolved
We have completed our monitoring period and are considering the issue fully resolved. If you are seeing any new issues, please let us know at https://support.box.com.
Posted Oct 19, 2020 - 11:20 PDT
Monitoring
We have observed a full recovery and we will continue to monitor this issue.
Posted Oct 19, 2020 - 10:03 PDT
Update
We continue to see recovery and stabilization across all Box services. Next update in 30 minutes or status change.
Posted Oct 19, 2020 - 09:33 PDT
Update
We are seeing initial signs of recovery. Users should notice less of an impact at this time, as we continue to monitor and remediate this issue.
Posted Oct 19, 2020 - 08:59 PDT
Update
We appreciate your patience while we continue to look into this issue. Next update to be sent in 30 minutes or status change.
Posted Oct 19, 2020 - 08:30 PDT
Update
We are continuing to investigate this issue. Users may also experience 500 errors with API.
Posted Oct 19, 2020 - 08:00 PDT
Update
The investigation is ongoing. Users may experience slow response times on Box.com and may encounter the error, "Sorry, we can't access that page." when attempting to log in.
Posted Oct 19, 2020 - 07:37 PDT
Update
We are continuing to investigate this issue.
Posted Oct 19, 2020 - 07:28 PDT
Investigating
We are currently investigating an ongoing issue affecting the Box API including uploads and downloads. Logging in and accessing content may also be impacted. We will provide more information as soon as it is available.
Posted Oct 19, 2020 - 06:45 PDT
This incident affected: Box Platform / API (Content API, Uploads/Downloads), Box Web Application (Login/SSO, Uploads/Downloads), Mobile Applications (Login/SSO, Uploads/Downloads), and Desktop Applications (Login/SSO, Box Sync, Box Drive).