[Major] Issue with Box Drive and Box Sync
Incident Report for Box
Postmortem

NOTICE AND DISCLAIMER: BOX IS PROVIDING THIS PRELIMINARY INFORMATION SUBJECT TO FURTHER REVIEW AND ANALYSIS. TO THE BEST OF OUR KNOWLEDGE, THIS IS THE CURRENT STATE AND WE WILL UPDATE AS MORE INFORMATION IS CONFIRMED.

LAST UPDATED: November 5, 2020

We recently addressed issues where file update events being delivered to Box Drive and Box Sync customers were significantly delayed. Below you will find further explanation of these issues and the preventative steps taken to mitigate future risk.

Between 8:09 AM PT and 6:40 PM PT on October 9, 2020 and between 5:54 PM PT and 11:13 PM PT on October 13, 2020, some users may have experienced difficulties while working in Box. During this time, file update events that were delivered from Box Cloud to Box Drive and Box Sync applications were significantly delayed. The delay caused late notifications of updates to files and folders in the users' Box folder. The issue occurred due to component restarts of services in the processing pipeline that delivers these events to the applications.  We were able to resolve the issue by minimizing planned service restarts during on-peak hours and performing them during off-peak times instead. In addition, Box will continue to monitor the services to ensure they are operating within expected performance benchmarks and ensure restarts occur during off-peak hours to prevent similar issues from occurring in the future.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Nov 05, 2020 - 17:02 PST

Resolved
Our teams have validated that all affected services are recovered at this time. No additional impact has been observed and this incident is now considered Resolved. Please contact Box Support at https://support.box.com if you experience any additional issues.
Posted Oct 09, 2020 - 19:53 PDT
Update
In addition to latency with Box Drive and Box Sync, we are seeing delayed event delivery with our long-polling API endpoint. Our teams are continuing to take action to remediate impact and are seeing early signs of improvement. We will provide additional updates on Saturday, October 10 around 9:00 am Central Daylight Time or at the next change in status.
Posted Oct 09, 2020 - 16:57 PDT
Identified
We have identified the cause of latency with Box Drive and Box Sync. Users may continue to see the following: Changes in Box Web Application will not reflect within Drive or Sync. Any changes within Drive or Sync will only reflect within the Web Application.
Posted Oct 09, 2020 - 15:08 PDT
Investigating
We are investigating latency with syncing from the Box Web Application to Box Applications: Box Drive, and Box Sync. Any changes in Box will not reflect within Drive or Sync. Any changes within Drive or Sync will only reflect within the Web Application.
Posted Oct 09, 2020 - 12:33 PDT
This incident affected: Box Platform / API (Content API) and Desktop Applications (Box Sync, Box Drive).