Issues with accessing Box.com
Incident Report for Box
Postmortem

We recently addressed an issue affecting new connections to Box.com. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

On April 14, 2021 between 4:34 PM PDT and 4:43 PM PDT, some users may have experienced issues while connecting to Box.com. The issue arose in connection with the release of a web application intended to improve end-user performance. We were able to resolve this issue by rolling back the deployment of the web application. We are working to improve our deployment management process to prevent similar issues from occurring in the future. 

Analysis 

This issue arose in connection with the release of a web application intended to improve end-user performance. As part of that release, there was a manual change to the data centers to which static assets are deployed for the Box web application. In this case, newly provisioned DM was not part of the release scripts. This created a discrepancy between available data centers and the expected data centers for the Box web application, resulting in issues for users connecting to Box.com.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Improve and automate the way Box manages static asset deployment to remove the possibility of a mismatch between available data centers and what the Box web application expects to be available.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Jul 20, 2021 - 13:40 PDT

Resolved
From approximately 4:34PM to 4:43 PM US Pacific time, we observed issues loading the Box site. Our systems automatically detected and corrected the underlying issue. There is no current impact and no further updates will be provided here. If you are currently seeing any issues, please let us know at https://support.box.com.
Posted Apr 14, 2021 - 04:30 PDT