[Critical] Issues accessing Box for Salesforce
Incident Report for Box
Postmortem

We recently addressed issues affecting the Box for Salesforce Integration. We would like to take this opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 12:17 PM PDT and 7:36 PM PDT on Friday, November 3, 2023, some users may have experienced difficulties while using our Box for Salesforce integration. During this time, customers using the integration experienced issues loading the Box Folder widgets, toolkit automation, and authentication flows. This occurred as a result of a back-end change that resulted in the integration's authentication credentials being invalidated. We were able to resolve the issue by resetting the credentials. In addition, we are updating our change control processes and software to prevent similar issues from occurring in the future.

Analysis

The Box Developer Console is part of our main web application, and is an interface that developers use to manage their application’s properties. The console also includes functionality to reset application credentials when necessary, which is typically reserved for credential rotations or similar scenarios. In this issue, the functionality to reset the application credentials was inadvertently triggered during other, more routine updates. As a result of these invalidated credentials, some users may have temporarily experienced difficulties using the integration. The issue was detected by Box employees within minutes of the change, and we were able to resolve the issue by restoring the application’s credentials.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Restoring the Box for Salesforce integration’s credentials
  • Update tooling and processes so that routine, low risk updates to applications are separated from rare, but necessary high risk capabilities, like resetting application credentials.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here, and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Nov 20, 2023 - 11:03 PST

Resolved
After further monitoring, this incident is now considered resolved. Box for Salesforce has been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Nov 03, 2023 - 19:41 PDT
Monitoring
Our team has implemented a fix and is currently monitoring the results.
Posted Nov 03, 2023 - 19:31 PDT
Update
Our team is in the process of deploying a change to help remediate this issue. We will continue to provide updates as they become available.
Posted Nov 03, 2023 - 18:26 PDT
Update
We are continuing to work on a fix for this issue.
Posted Nov 03, 2023 - 16:45 PDT
Identified
Our team continues remediation efforts to restore full functionality to Box for Salesforce. We will provide additional updates as they become available.
Posted Nov 03, 2023 - 15:35 PDT
Update
Our team has identified the underlying cause of this issue affecting Box for Salesforce and is working to take remediating steps. We will provide additional updates as they become available.
Posted Nov 03, 2023 - 15:06 PDT
Investigating
Our team is investigating an issue with Box for Salesforce. Users may see errors using or logging into Box for Salesforce. We will provide additional information as it becomes available.
Posted Nov 03, 2023 - 14:57 PDT
This incident affected: Partners / Integrations (Box for Salesforce).