[Major] Customers may experience issues with Microsoft Office integration
Incident Report for Box
Postmortem

We recently addressed issues affecting the Office Online integration. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 02:48 AM and 04:06AM PT on January 18, 2024, some users may have experienced difficulties while working in Box. During this time, Box customers were unable to open or edit Microsoft Office files via Office Online. The issue occurred as a result of network connectivity issues. We were able to resolve the issue by restoring the network connectivity. In addition, we are working to make the Office Online integration more resilient to such failures, to prevent similar issues from occurring in the future. 

_Analysis _

The Office Online integration communicates with Microsoft servers in order to provide Office for the Web capabilities for files hosted in Box. This communication happens via the Web Application Open Platform Interface (WOPI) protocol.

Box performs signature validation of each WOPI command it receives. The cryptographic keys needed to perform this validation are acquired through a process called WOPI discovery. During the discovery process, Box fetches an XML file from the Microsoft servers. This file contains the keys needed to perform signature validation. The file is then cached for a period of time.

Prior to the outage, the discovery endpoint for one of the Office Online environments became briefly unreachable. At the same time, the cache on the Box side expired. Box then failed to refetch the discovery XML for one of the environments, which caused the signature validation to fail in a cascading way across all other environments.

Corrective Actions

The following corrective actions have been completed or are planned:

  • The cache time-to-live for the discovery file will be increased, to reduce Box’s exposure to any failures to reach the discovery endpoint
  • Changes will be made to ensure that failures to acquire discovery information for one Office Online environment do not impact other environments

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Mar 01, 2024 - 12:18 PST

Resolved
After further monitoring, this incident is now considered resolved. Service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Jan 18, 2024 - 05:08 PST
Monitoring
We are seeing improvement across all Microsoft Office Integration services. We are continuing to monitor for any additional impact.
Posted Jan 18, 2024 - 04:11 PST
Investigating
Our team is investigating an issue with Microsoft Office integration. Users may see errors using Microsoft Office integrations. We will provide additional information as it becomes available.
Posted Jan 18, 2024 - 03:43 PST
This incident affected: Partners / Integrations (Microsoft Online).