[Minor] Customers may be experiencing issues with uploads and downloads

Incident Report for Box

Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we may update as more information is confirmed.

On March 21, 2025 between 9:04 am PST and 10:32 am PST, some users may have experienced difficulties while working in Box. During this time customers of Box Zones Germany and Box Zones France may have experienced issues with uploading, downloading and previewing files.

The issue occurred due to a configuration change in a backend service used to provide Box Zones. We resolved the issue by temporarily redirecting certain compute processes from the impacted region to the US region and then reverting the configuration change. After mitigating the issue, we shifted the traffic back at 1:24 PM PDT. Importantly, even during the period of temporary traffic redirection, all Box Zones customer content continued to be stored in the correct Box Zones region.

We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. In the event our continuing investigation yields further substantive findings, we may publish additional analysis after the conclusion of the full engineering postmortem.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Mar 27, 2025 - 08:34 PDT

Resolved

After further monitoring, this incident is now considered resolved. Our Service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Mar 21, 2025 - 11:07 PDT

Monitoring

Our team has taken steps to remediate this issue and is seeing improvement for uploads and downloads. We are continuing to monitor for any additional impact.
Posted Mar 21, 2025 - 10:40 PDT

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Mar 21, 2025 - 10:21 PDT

Update

We are continuing to investigate this issue.
Posted Mar 21, 2025 - 09:53 PDT

Update

We are continuing to investigate this issue.
Posted Mar 21, 2025 - 09:50 PDT

Investigating

We are investigating an ongoing issue affecting uploads and downloads. We will provide more information as soon as it is available.
Posted Mar 21, 2025 - 09:50 PDT
This incident affected: Box Web Application (Uploads/Downloads).