[Major] Issues with Box Sign
Incident Report for Box
Postmortem

We recently addressed issues affecting Box Sign. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 2:41 AM and 2:51 PM PDT on March 26, 2024, some users may have experienced difficulties while working in Box Sign. During this time, the users were unable to send manual reminders for pending Sign requests, and delete sign requests in the WebApp.

Analysis

The issue occurred as a result of a recent code change made to improve Box Sign functionality. The issue presented itself in the sign mechanism for request handling, resulting in the sign reminder and delete functionalities not being available to the users. Incomplete automated testing coverage and pre-release checks for the functionalities mentioned above allowed the issue to go undetected before production deployment. We were able to quickly resolve the issue by performing a rollback of the sign web service. In addition, we are working on improving our monitoring system, pre-release quality check procedures, engineering on-call documentation and the robustness of the sign request handling mechanism to prevent similar issues from occurring in the future.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Enhancing monitoring and alerts graphs in the sign service
  • Increasing the integration test coverage of the area affected in the incident (and adjacent ones)
  • Updating the sign engineering on-call documentation, as part of the effort to facilitate the improvement of detection and resolution time
  • Improving the robustness of the sign request handling mechanism

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Apr 01, 2024 - 10:52 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Mar 26, 2024 - 16:38 PDT
Monitoring
We have resolved the issue impacting Box Sign. We are continuing to monitor to ensure no further impact is observed
Posted Mar 26, 2024 - 16:03 PDT
Identified
Box continues remediation efforts to restore full functionality to Box Sign. The potential cause of the issue has been identified and efforts are underway to restore stability.
Posted Mar 26, 2024 - 15:35 PDT
Investigating
We are investigating an ongoing issue with Box Sign. Customers may experience issues modifying Box Sign requests. We will provide more information as soon as it is available.
Posted Mar 26, 2024 - 15:21 PDT
This incident affected: Box Web Application (Box Sign).