[Minor] Searching in "Users & Groups" within Admin Console will not generate results
Incident Report for Box
Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we will update as more information is confirmed.

We recently addressed issues that resulted in the search feature not working as expected in Users and Groups in the Admin Console. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

From December 8, 2021 at 3:36 PM PT until December 9, 2021 at 12:25 PM PT, some users may have experienced difficulties while attempting to use the search feature in the Users and Groups pages in the Admin Console. This issue was caused by an update not working as anticipated. We were able to resolve the issue by reverting to the previous release until we were able to identify and remedy the issue in the update.

Analysis 
The issue occurred as a result of certain updates that did not work as expected. As part of these updates, some keywords were included in the code that were not compatible with some of the newer dependencies installed. We were able to resolve the issue by reverting to the previous release. In addition, we updated the code at issue to use more modern keywords to prevent similar issues from occurring in the future.

Corrective Actions
The following corrective actions have been completed or are planned:

  • We reverted to the previous working release of the Admin Console.
  • We identified the dependency issues and replaced incompatible keywords with more modern keywords.
  • We validated that the solution resolved the issue through manual and automated testing.
  • We plan to improve our testing to more effectively prevent similar issues from occurring in the future.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Dec 21, 2021 - 09:48 PST

Resolved
The issue impacting the ability to search within Users and Groups in the Admin Console is now resolved. If you are still encountering any issues please reach out to us at https://support.box.com.
Posted Dec 09, 2021 - 12:42 PST
Investigating
We have received reports that the search function within the Users & Groups tab of the Admin Console is not providing results.

Our teams are currently engaged to address this behavior and we will provide additional updates as they become available.
Posted Dec 09, 2021 - 12:10 PST
This incident affected: Box Web Application (Search).