[Minor] Issues Accessing Box
Incident Report for Box
Postmortem

We recently addressed issues affecting access to Box for some customers. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 2:13 am PST and 2:55 am PST on December 1, 2022, some users may have experienced difficulties while working in Box. During this time. users of some enterprises with Device Trust checks enabled may have experienced intermittent 500 errors when logging in to Box or accessing the All Files page.

Analysis

The issue occurred as a result of a recent code change related to Box's Device Trust feature. Due to incorrect estimates of user traffic, the authentication flow service would transiently block some users from accessing Box. We were able to revert the problematic code and correct faulty assumptions in the days following the incident. In addition, our performance testing has been revised and new observability measures have been implemented to prevent similar issues from occurring in the future. 

Corrective Actions

The following corrective actions have been completed or are planned:

  • Improving Device Trust performance testing process to provide a reasonable safety buffer.
  • Improving Device Trust observability to revert faulty changes at the time of deployment.
  • Increasing Device Trust hardware resources.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Dec 12, 2022 - 09:43 PST

Resolved
From approximately 2:13AM-2:55AM PT, some users may have experienced intermittent 500 errors when logging in to Box or accessing the All Files page. This issue was automatically detected by our internal monitoring and a fix was implemented. If you are still experiencing any issues with these services, please contact Box Support via https://support.box.com.
Posted Dec 01, 2022 - 02:15 PST