[Major] Issue with Uploads, Downloads, Preview and Box Notes
Incident Report for Box
Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we will update as more information is confirmed.

On January 8, 2021 between 12:52 PM and 1:34 PM PST, some users may have experienced difficulties while working in Box. During this time, all enterprises on one specific shard may have had issues with Uploads, Downloads, Notes and Preview. The issue occurred as a result of reverting a database configuration change in our ongoing effort to move some enterprises to a new shard to improve performance of users on that shard.  We were able to resolve the issue by rolling back the change that caused this issue. In addition, we are adding more tooling and processes to our current migration process to prevent similar issues from occurring in the future. 

We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. We will publish the results as soon as we have concluded our investigation.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.  

Sincerely,

The Box Team

Posted Jan 14, 2021 - 08:53 PST

Resolved
We have completed our monitoring period and are considering the issue fully resolved. If you are seeing any new issues, please let us know at https://support.box.com.
Posted Jan 08, 2021 - 14:03 PST
Monitoring
We have taken steps to to resolve this issue and are monitoring for any further impact. If you continue to see issues, please contact Box Support at https://support.box.com.
Posted Jan 08, 2021 - 13:44 PST
Investigating
We are currently investigating an ongoing issue affecting the Uploads, Downloads, Preview and Box Notes. We will provide more information as soon as it is available.
Posted Jan 08, 2021 - 13:30 PST
This incident affected: Box Notes (Web Application, Desktop Client), Box Web Application (Uploads/Downloads, Preview), Box Platform / API (Content Preview, Uploads/Downloads), Desktop Applications (Box Sync, Box Drive, Box Edit / Tools), and Mobile Applications (Preview, Uploads/Downloads).