Some users may receive multiple emails for collaboration acceptance notifications
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further issues have been observed with duplicate email notifications. If you continue to receive duplicate email notifications, please contact Box User Services via https://community.box.com/t5/Contact-Support/ct-p/BoxSupport.
Posted 10 months ago. Oct 25, 2017 - 17:55 PDT
Monitoring
Box Engineering has remediated the issue causing the extra email notifications and is monitoring to ensure no further issues occur.
Posted 10 months ago. Oct 25, 2017 - 17:07 PDT
Identified
Box Engineering has identified an issue which may cause some users to receive multiple email notifications about other users accepting the invitation to collaborate on a folder.
Posted 10 months ago. Oct 25, 2017 - 16:14 PDT
This incident affected: Email Notifications.