[Minor] Issue with Admin Reporting

Incident Report for Box

Resolved

This incident is now resolved and Box services have been restored to full functionality. If you generated reports during the impacted period, please re-run those reports. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Sep 03, 2026 - 20:03 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2026 - 19:16 PDT

Investigating

Our team is investigating an issue with Admin Reporting. Users may experience inconsistent data in reports generated after approximately 3:30 PM Pacific Time. We will provide additional information as it becomes available.
Posted Sep 03, 2026 - 19:10 PDT
This incident affected: Box Web Application (Enterprise Reports).