[Major] Customers may experience issues with Logins, Uploads, and Box Notes
Incident Report for Box
Resolved
After further monitoring, this incident is now considered resolved. All Box features have been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Mar 01, 2024 - 14:46 PST
Monitoring
Our team has taken steps to remediate this issue and the affected services should be returning to full functionality. We are continuing to monitor for any additional impact.
Posted Mar 01, 2024 - 14:23 PST
Investigating
Our team is investigating an issue with Logins, Uploads, and Box Notes. Users attempting to use these services may see errors or timeouts. We will provide additional information as it becomes available.
Posted Mar 01, 2024 - 14:05 PST
This incident affected: Box Web Application (Login/SSO, Uploads/Downloads) and Box Notes (Web Application).