[Minor] Customers may have experienced issues using Public API
Incident Report for Box
Postmortem

We recently addressed issues affecting Box Public API. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 6:04 PM and 6:14 PM PST on April 14, 2024, some users may have experienced difficulties with Box Public APIs. During this time, some public API requests failed and there may have been a brief increase in latency. The issue occurred due to an unexpected spike in authentication requests and resolved as the traffic returned to normal. We are working on improvements to prevent similar issues from occurring in the future.

Analysis

An unexpected spike in traffic to one of our authentication databases coupled with an inefficient query in our application caused a brief delay in data replication. The replication recovered automatically, resolving the impact. Our team has investigated this issue and will be making changes to optimize the inefficient query.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Optimize database query by adding index
  • Avoid retrieving unnecessary metadata as part of authentication to improve performance and resilience

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Apr 30, 2024 - 14:10 PDT

Resolved
Between 6:04PM and 6:12PM PDT on April 14th 2024, some users may have experienced issues using Public API. No further impact has been observed and we are considering this issue to be resolved. If you are still experiencing any issues, please let us know at https://support.box.com.
Posted Apr 14, 2024 - 18:44 PDT
This incident affected: Box Platform / API (Content API).